Skip to main content
CVE-2026-124553VulnerabilityPublished

BabelDOC from 0.3.61 before 0.7.0 contains a resource exhaustion vulnerability that allows remote attackers to exhaust

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-124553· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 0.7.0 soon.

Data as of 8 Nov 2026, 17:50 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.17.5
Patch
Available – fixed in 0.7.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade BabelDOC to 0.7.0.

Affected software

ProductAffectedFixed in
funstory-aiBabelDOCAffected
  • >=0.3.61 <0.7.0
Fixed in
  • 0.7.0
PyPIBabelDOCpkg:pypi/BabelDOCOther threatsAffected
  • >=0.3.61 <0.7.0
Fixed in
  • 0.7.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider restricting or scanning PDF inputs to detect unusually large ToUnicode CMap ranges to mitigate potential exploitation.

Description

BabelDOC versions from 0.3.61 up to but not including 0.7.0 contain a resource exhaustion vulnerability. This flaw allows remote attackers to exhaust CPU and memory resources by submitting a crafted PDF with an embedded ToUnicode CMap that declares an excessively large range. The vulnerability causes billions of loop iterations in the translation worker, leading to a denial of service condition.

References

Community reviews

Loading reviews…