Skip to main content
VulnerabilityPublished Updated

CVE-2024-11079: Bbot · Ansible-Core vulnerable to content protections bypass

Affects bbotSource GCVE Database

0
Compare
Authoritative record:CVE-2024-11079· Medium 5.5

Not known to be exploited · CVSS 5.5 Medium : upgrade to 2.4.0 when convenient.

Data as of 30 Oct 2026, 07:30 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade bbot to 2.4.0.

Affected software

ProductAffectedFixed in
Homebrewbbotpkg:brew/bbotOther threatsAffected
  • >=1.0.5.1665 <2.4.0
Fixed in
  • 2.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A flaw was found in Ansible-Core. This vulnerability allows attackers to bypass unsafe content protections using the hostvars object to reference and execute templated content. This issue can lead to arbitrary code execution if remote data or module outputs are improperly templated within playbooks.

References

Community reviews

Loading reviews…