Skip to main content
CVE-2026-67336VulnerabilityPublished

better-auth versions before 1.6.11 contain insecure cryptographic defaults in the oidcProvider and mcp plugins that advertise the none algorithm and accept plain PKCE by default

Affects better-authSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.6.11 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.11
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade better-auth/better-auth to 1.6.11.

Affected software

ProductAffectedFixed in
GitHubbetter-auth/better-authpkg:github/better-auth/better-authOther threatsAffected
  • <1.6.11
Fixed in
  • 1.6.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in better-auth version 1.6.11 that addresses these insecure cryptographic defaults. Users should upgrade to version 1.6.11 or later to mitigate this vulnerability. No other mitigation guidance is provided or required beyond applying the official fix.

Description

better-auth versions before 1.6.11 contain insecure cryptographic defaults in the oidcProvider and mcp plugins that advertise the none algorithm and accept plain PKCE by default. Attackers can exploit algorithm negotiation to accept unsigned tokens or intercept authorization codes when PKCE plain is used instead of the required S256 method.

References

Community reviews

Loading reviews…