Skip to main content
VulnerabilityPublished Updated

CVE-2026-34154: Discourse Has a Subscription Access Bypass

Affects discourseSource GCVE Database

0
Compare

Not known to be exploited · fixed in 2026.4.1 : update discourse when convenient.

Data as of 30 Oct 2026, 06:59 UTC

Severity
Low

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.4.1, 2026.3.1, 2026.1.4

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade discourse to 2026.4.1, 2026.3.1 or 2026.1.4.

Affected software

ProductAffectedFixed in
Bitnamidiscoursepkg:bitnami/discourseOther threatsAffected
  • <2026.1.4
  • >=2026.3.0 <2026.3.1
  • >=2026.4.0 <2026.4.1
Fixed in
  • 2026.1.4
  • 2026.3.1
  • 2026.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Discourse to version 2026.1.4, 2026.3.1, 2026.4.1, or later versions such as 2026.5.0 where the vulnerability has been fixed. No other mitigation is indicated or required.

Description

Discourse versions prior to 2026.1.4, 2026.3.1, and 2026.4.1 contain a vulnerability in the discourse-subscriptions plugin that allows users to bypass subscription payment requirements and gain access to subscription-gated groups. This issue has been fixed in versions 2026.1.4, 2026.3.1, 2026.4.1, and 2026.5.0. The severity of this vulnerability is considered low.

References

Community reviews

Loading reviews…