Skip to main content
CVE-2025-13761VulnerabilityPublished Updated

BIT-gitlab-2025-13761: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited : upgrade to 18.7.1 or 18.6.3 as a priority.

Data as of 26 Oct 2026, 06:26 UTC

Severity
Critical

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.7.1, 18.6.3

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade gitlab to 18.7.1 or 18.6.3.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=18.6.0 <18.6.3
  • >=18.7.0 <18.7.1
Fixed in
  • 18.6.3
  • 18.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitLab to versions 18.6.3 or later, or 18.7.1 or later, where this vulnerability has been fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.

Description

A critical cross-site scripting (XSS) vulnerability exists in GitLab Community and Enterprise Editions affecting versions from 18.6 up to but not including 18.6.3, and 18.7 up to but not including 18.7.1. This vulnerability could allow an unauthenticated attacker to execute arbitrary code in the context of an authenticated user's browser by tricking the user into visiting a specially crafted webpage. GitLab has remediated this issue in versions 18.6.3 and 18.7.1.

References

Community reviews

Loading reviews…