CVE-2026-42266: JupyterLab has an Extension Manager API/GUI Policy Discrepancy allowing 3rd party (malicious)
Affects jupyterlabSource GCVE Database
Not known to be exploited : upgrade to 4.5.7 soon.
Data as of 26 Oct 2026, 17:16 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 5.6% chance of exploitation in 30 days – higher than 92% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.5.7
Exploitation evidence
Disclosed: evidence found.
CVE published 15 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade jupyterlab to 4.5.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamijupyterlabpkg:bitnami/jupyterlabOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade JupyterLab to version 4.5.7 or later, where the vulnerability is fixed. Alternatively, configure the JupyterLab extension manager to read-only mode to prevent installation of unauthorized extensions. Note that using a PyPI proxy with an allow list is insufficient to mitigate this vulnerability. Follow vendor advisories for detailed remediation steps.
Description
JupyterLab versions from 4.0.0 up to but not including 4.5.7 contain a vulnerability in the PyPI Extension Manager that fails to enforce the allow-list of approved extensions. This flaw allows installation of unauthorized third-party extensions from sources outside the default PyPI index. Exploitation could lead to arbitrary code execution and significant system compromise. The issue is fixed in version 4.5.7. Mitigation includes upgrading to 4.5.7 or later and setting the extension manager to read-only mode to prevent unauthorized extension installation.
References
- github.com/jupyterlab/jupyterlab/security/advisories/GHSA-37w4-hwhx-4rc4 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-42266 (opens in a new tab)
- github.com/jupyterlab/jupyterlab/releases/tag/v4.5.7 (opens in a new tab)
- jupyterhub.readthedocs.io/en/5.2.1/explanation/websecurity.html (opens in a new tab)
- jupyterlab.readthedocs.io/en/latest/user/extensions.html (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-42266 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2477072 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42266.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:43038 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:60520 (opens in a new tab)