Skip to main content
CVE-2026-122138VulnerabilityPublished

BlueprintUE Self-Hosted Edition 4.2.0 before 4.3.4 contains a login rate limit bypass vulnerability in

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-122138· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade to 4.3.4 when convenient.

Data as of 4 Nov 2026, 22:39 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.3
CNA (VulnCheck)CVSS 3.15.3
Patch
Available – fixed in 4.3.4
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade blueprintue-self-hosted-edition to 4.3.4.

Affected software

ProductAffectedFixed in
blueprintueblueprintue-self-hosted-editionAffected
  • >=4.2.0 <4.3.4
Fixed in
  • 4.3.4
GitHubblueprintue-self-hosted-editionpkg:github/blueprintue-self-hosted-editionOther threatsAffected
  • >=4.2.0 <4.3.4
Fixed in
  • 4.3.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in BlueprintUE Self-Hosted Edition version 4.3.4 and later. Users should upgrade to version 4.3.4 or newer to remediate this vulnerability. No other mitigation guidance is provided or necessary as the issue is resolved by the official patch.

Description

BlueprintUE Self-Hosted Edition versions from 4.2.0 up to but not including 4.3.4 have a login rate limit bypass vulnerability. The flaw exists because the login middleware keys failed-login counters on case-sensitive usernames, while the underlying MySQL lookups are case-insensitive. This mismatch allows unauthenticated attackers to bypass per-account lockout by varying username casing and thus gain additional brute-force attempts.

References

Community reviews

Loading reviews…