Skip to main content
CVE-2026-122139VulnerabilityPublished

blueprintUE Self-Hosted Edition before 4.3.3 contains an account enumeration vulnerability in

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-122139· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 4.3.3 when convenient.

Data as of 4 Nov 2026, 22:39 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.15.3
Patch
Available – fixed in 4.3.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade blueprintue-self-hosted-edition to 4.3.3.

Affected software

ProductAffectedFixed in
blueprintueblueprintue-self-hosted-editionAffected
  • <4.3.3
Fixed in
  • 4.3.3
GitHubblueprintue-self-hosted-editionpkg:github/blueprintue-self-hosted-editionOther threatsAffected
  • <4.3.3
Fixed in
  • 4.3.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in blueprintUE Self-Hosted Edition version 4.3.3 and later. Users should upgrade to version 4.3.3 or newer to remediate this vulnerability. Until patched, implementing rate limiting on password reset requests can help reduce the risk of automated enumeration attempts.

Description

blueprintUE Self-Hosted Edition versions before 4.3.3 have an account enumeration vulnerability in the ForgotPasswordMiddleware.php component. This flaw allows unauthenticated attackers to determine whether an email address is registered by observing differences in password reset redirect behavior. The vulnerability is exacerbated by the lack of rate limiting on failed lookup attempts, enabling unlimited enumeration.

References

Community reviews

Loading reviews…