CVE-2026-111497: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package
Affects Google scrapySource GCVE Database
Exploited in the wild · KEV due 10 Nov 2026 · 82% EPSS : upgrade to 2.19.0_2 now.
Data as of 30 Oct 2026, 06:59 UTC
Thin evidence
One scorer or none| CNA (Google) | CVSS 4.0 | 9.2 |
|---|
- KEV deadline
- US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
- EPSS
- 82.6% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.19.0_2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: evidence found.
Listed in CISA KEV 5 days after disclosure
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE ID reserved
by Google LLC
, 6 days before disclosure
CVE published
on cve.org
, t = 0
In Threat Radar
record ingested
, 4 days after disclosure
Added to CISA KEV (opens in a new tab)
exploitation confirmed
, 5 days after disclosure
KEV remediation due
US federal deadline
, 19 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Google scrapy to 2.19.0_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewscrapypkg:brew/scrapyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
A buffer overflow vulnerability exists in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0. This flaw allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, potentially leading to sensitive memory disclosure, denial of service, or arbitrary code execution. Users should update affected Brotli libraries or binaries to fixed versions 1.0.10, 1.1.1, or 1.2.1. The vulnerability is rated critical with a CVSS 4.0 score of 9.2.
References
- nvd.nist.gov/vuln/detail/CVE-2026-111497 (opens in a new tab)
- github.com/dotnet/announcements/issues/494 (opens in a new tab)
- github.com/google/brotli/commit/0ed4268a4401abcb4472096340477cf4af7d1a2b (opens in a new tab)
- github.com/google/brotli/commit/50a9b70a4d5e1443fc40927952276b68fffa83a0 (opens in a new tab)
- github.com/google/brotli/commit/b418fa81c48262a86a95332b0bc6d62c30aa78b6 (opens in a new tab)
- github.com/google/brotli/commit/da9806362874b9bd4b552a3af360b5d6347beb12 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-111497 (opens in a new tab)
- cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-111497 (opens in a new tab)
- aikido.dev/blog/node2shell-nodejs-brotli-rce-cve-2026-111497 (opens in a new tab)
- pypi.org/project/brotlicffi (opens in a new tab)
- pypi.org/project/Brotli (opens in a new tab)
- patchtheplanet.org/brotli (opens in a new tab)
- opensourcemalware.com/blog/node2shell-affects-python (opens in a new tab)
- nodejs.org/en/blog/vulnerability/october-2026-security-releases (opens in a new tab)
- nodejs.org/en/blog/vulnerability/october-2026-security-releases (opens in a new tab)
- lists.debian.org/debian-lts-announce/2026/10/msg00049.html (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/brotlicffi/PYSEC-2026-4323.yaml (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/brotli/PYSEC-2026-4322.yaml (opens in a new tab)
- github.com/google/brotli/releases/tag/v1.2.1 (opens in a new tab)
- github.com/google/brotli/releases/tag/v1.1.1 (opens in a new tab)