Skip to main content
VulnerabilityPublished

CVE-2026-111497: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package

Affects fonttoolsSource GCVE Database

0
Authoritative record:CVE-2026-111497· Critical 9.2

Not known to be exploited · 36% EPSS · CVSS 9.2 Critical : upgrade to 4.67.0_1 or 4.45.0 as a priority.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
36.0% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.67.0_1, 4.45.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade fonttools to 4.67.0_1 or 4.45.0.

Affected software

ProductAffectedFixed in
Homebrewfonttoolspkg:brew/fonttoolsOther threatsAffected
  • >=4.34.4_1 <4.45.0
  • >=4.49.0 <4.67.0_1
Fixed in
  • 4.45.0
  • 4.67.0_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream. Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.

References

Community reviews

Loading reviews…