Skip to main content
VulnerabilityPublished Updated

CVE-2026-111497: brotli vulnerability

Affects Google brotliSource GCVE Database

0
Compare
Authoritative record:CVE-2026-111497· Critical 9.2

Exploited in the wild · KEV due 10 Nov 2026 · fixed in 1.0.3-1ubuntu1~16.04.2+esm1 : patch Google brotli now.

Data as of 29 Oct 2026, 22:33 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Google)CVSS 4.09.2
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 1.0.3-1ubuntu1~16.04.2+esm1, 1.0.3-1ubuntu1.3+esm1, 1.0.7-6ubuntu0.1+esm1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 5 days after disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Google LLC

    , 6 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 4 days after disclosure

  4. , 5 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 19 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu brotli to 1.0.3-1ubuntu1~16.04.2+esm1 (package) or 1.0.3-1ubuntu1.3+esm1 (package) or 1.0.7-6ubuntu0.1+esm1 (package).

Affected software

ProductAffectedFixed in
Ubuntu Pro 20.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=esm-infra/focalOther threatsAffected
  • <1.0.7-6ubuntu0.1+esm1
Fixed in
  • 1.0.7-6ubuntu0.1+esm1
Ubuntu Pro 18.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <1.0.3-1ubuntu1.3+esm1
Fixed in
  • 1.0.3-1ubuntu1.3+esm1
Ubuntu Pro 16.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • <1.0.3-1ubuntu1~16.04.2+esm1
Fixed in
  • 1.0.3-1ubuntu1~16.04.2+esm1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

USN-8956-1 fixed a vulnerability in Brotli. This update provides the corresponding fixes for Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. Original advisory details: It was discovered that Brotli incorrectly handled certain compressed streams. A remote attacker could possibly use this issue to cause a denial of service or execute arbitrary code.

References

Community reviews

Loading reviews…