Skip to main content
VulnerabilityPublished

CVE-2026-111497: brotli vulnerability

Affects brotliSource GCVE Database

0
Authoritative record:CVE-2026-111497· Critical 9.2

Not known to be exploited · CVSS 9.2 Critical · fixed in 1.0.9-2ubuntu0.1 : patch brotli as a priority.

Data as of 26 Oct 2026, 22:59 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.0.9-2ubuntu0.1, 1.1.0-2ubuntu0.1, 1.2.0-4ubuntu0.1 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10brotlipkg:deb/ubuntu/brotli?arch=source&distro=stonkingOther threatsAffected
  • <1.2.0-4ubuntu0.1
Fixed in
  • 1.2.0-4ubuntu0.1
Ubuntu 26.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=resoluteOther threatsAffected
  • <1.2.0-3ubuntu0.1
Fixed in
  • 1.2.0-3ubuntu0.1
Ubuntu 24.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=nobleOther threatsAffected
  • <1.1.0-2ubuntu0.1
Fixed in
  • 1.1.0-2ubuntu0.1
Ubuntu 22.04 LTSbrotlipkg:deb/ubuntu/brotli?arch=source&distro=jammyOther threatsAffected
  • <1.0.9-2ubuntu0.1
Fixed in
  • 1.0.9-2ubuntu0.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available and users should update their Brotli packages to the following versions or later: 1.0.9-2ubuntu0.1, 1.1.0-2ubuntu0.1, 1.2.0-4ubuntu0.1, or 1.2.0-3ubuntu0.1 depending on their Ubuntu release. Applying standard system updates will install these patches. No additional mitigation steps are required beyond updating to the fixed versions.

Description

A vulnerability in Brotli was discovered where it incorrectly handled certain compressed streams. This flaw could allow a remote attacker to cause a denial of service or execute arbitrary code by providing specially crafted input. The issue affects multiple Ubuntu package versions and has been addressed in updated releases. Users are advised to update to the fixed package versions to mitigate the risk.

References

Community reviews

Loading reviews…