Skip to main content
CVE-2026-114645VulnerabilityPublished Updated

SUSE · bson-devel-2.5.7-1.1 on GA media

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-114645· Medium 5.7

Not known to be exploited · CVSS 5.7 Medium : upgrade SUSE mongo-c-driver to 2.5.7 or 1.30.14 when convenient.

Data as of 4 Nov 2026, 02:43 UTC

CVSS 4.0 base score
5.7Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mongodb)CVSS 4.05.7
CNA (mongodb)CVSS 3.15.2
Patch
Available – fixed in 2.5.7, 1.30.14
CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:L/VI:L/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade C Driver and mongodb/mongo-c-driver to 2.5.7 or 1.30.14.

Affected software

ProductAffectedFixed in
MongoDBC DriverAffected
  • >=2.0.0 <2.5.7
Fixed in
  • 2.5.7
MongoDBC DriverAffected
  • >=1.6.0 <1.30.14
Fixed in
  • 1.30.14
GitHubmongodb/mongo-c-driverpkg:github/mongodb/mongo-c-driverOther threatsAffected
  • >=1.6.0 <1.30.14
  • >=2.0.0 <2.5.7
Fixed in
  • 1.30.14
  • 2.5.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to the bson-devel-2.5.7-1.1 package on openSUSE Tumbleweed, which contains fixes for the security issues. No additional mitigation guidance is provided.

Description

Multiple security issues were addressed in the bson-devel-2.5.7-1.1 package for openSUSE Tumbleweed. These fixes resolve vulnerabilities present in earlier versions of the package. No specific details about the nature of the vulnerabilities or their impact are provided.

References

Community reviews

Loading reviews…