Skip to main content
VulnerabilityPublished

CVE-2026-34059: Apache HTTP Server · Buffer Over-read Vulnerability

Source GCVE Database

0
Authoritative record:CVE-2026-34059· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 2.4.67 soon.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.67
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade apache/httpd to 2.4.67.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • <=2.4.66
Fixed in–
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <2.4.67
Fixed in
  • 2.4.67

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Buffer Over-read vulnerability in Apache HTTP Server. This issue affects Apache HTTP Server: through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

References

Community reviews

Loading reviews…