Skip to main content
CVE-2024-24476VulnerabilityPublished Updated

Wireshark team Wireshark · Buffer Overflow Vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2024-24476· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 4.2.0 : patch Wireshark soon.

Data as of 4 Nov 2026, 17:42 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Affects
Wireshark before 4.2.0
Patch
Available – fixed in 4.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

AI-suggested

A fix is available in Wireshark version 4.2.0 and later. Users should upgrade to version 4.2.0 or newer to remediate this vulnerability. Since this is not a cloud service, manual patching is required.

Description

A buffer overflow vulnerability exists in Wireshark versions before 4.2.0 in the pan/addr_resolv.c component, specifically in the ws_manuf_lookup_str() function. This flaw allows a remote attacker to cause a denial of service by triggering the overflow.

References

Community reviews

Loading reviews…