CVE-2026-120631: CGI::Cookie versions from 4.67 before 5.00 for Perl allow denial of service via the client cookie
Source GCVE Database
Not known to be exploited : upgrade to 5.00 soon.
Data as of 4 Nov 2026, 02:00 UTC
Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD
Thin evidence
One scorer or none- Patch
- Available – fixed in 5.00
Exploitation evidence
Disclosed: evidence found.
CVE published 3 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade CGI (Perl module) to 5.00.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| CGI | Affected
| Fixed in
|
CPANCGIpkg:cpan/CGIOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
CGI::Cookie versions from 4.67 up to but not including 5.00 for Perl contain a denial of service vulnerability. The flaw arises because the expires value from client cookies is used unescaped as a regular expression pattern in the parse method, allowing crafted input to cause process crashes or excessive backtracking.
References
- nvd.nist.gov/vuln/detail/CVE-2026-120631 (opens in a new tab)
- github.com/leejo/CGI.pm/commit/95e044af2ec24d99a61e99d6291580ad47aff641.patch (opens in a new tab)
- metacpan.org/release/LEEJO/CGI-4.72/source/lib/CGI/Cookie.pm (opens in a new tab)
- metacpan.org/release/LEEJO/CGI-5.00/changes (opens in a new tab)