Ch.qos.logback:logback core: QOS.CH logback-core is vulnerable to Arbitrary Code Execution through file processing
Affects ch.qos.logback:logback-coreSource GCVE Database
Not known to be exploited · CVSS 7.0 High : upgrade to 1.5.19 soon.
Data as of 29 Oct 2026, 23:33 UTC
- Patch
- Available – fixed in 1.5.19, 1.3.16
CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N/S:P/AU:N/RE:M/U:GreenExploitation evidence
Disclosed: evidence found.
CVE published 1 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade ch.qos.logback:logback-core to 1.5.19; ch.qos.logback:logback-core to 1.3.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavench.qos.logback:logback-core | Affected
| Fixed in
|
| Mavench.qos.logback:logback-core | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and fixed versions 1.5.19 and 1.3.16 should be applied to remediate this vulnerability. Users should upgrade to these fixed versions to eliminate the risk. No additional mitigation steps are indicated by the vendor advisory.
Description
QOS.CH logback-core versions prior to 1.5.19 and 1.3.16 are vulnerable to an arbitrary code execution flaw in conditional configuration file processing. Exploitation requires the presence of the Janino library and Spring Framework on the class path, as well as write access to a logback configuration file or the ability to inject a malicious environment variable. The vulnerability allows attackers with existing privileges to execute arbitrary code by compromising or injecting configuration files.
References
- nvd.nist.gov/vuln/detail/CVE-2025-11226 (opens in a new tab)
- github.com/qos-ch/logback/issues/974 (opens in a new tab)
- github.com/qos-ch/logback/commit/61f6a2544f36b3016e0efd434ee21f19269f1df7 (opens in a new tab)
- github.com/qos-ch/logback (opens in a new tab)
- github.com/qos-ch/logback/releases/tag/v_1.5.19 (opens in a new tab)
- logback.qos.ch/news.html (opens in a new tab)
- logback.qos.ch/news.html (opens in a new tab)