Skip to main content
CVE-2026-35035VulnerabilityPublished Updated

ci4-cms-erp/ci4ms · CI4MS: Company Information Public-Facing Page Full Platform Compromise & Full Account Takeover for All Roles &

Affects ci4-cms-erp/ci4msSource GCVE Database

0
Authoritative record:CVE-2026-35035· High 7.2

Not known to be exploited · CVSS 7.2 High : upgrade to 0.31.2.0 soon.

Data as of 27 Oct 2026, 00:29 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.31.2.0
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ci4-cms-erp/ci4ms to 0.31.2.0.

Affected software

ProductAffectedFixed in
Packagistci4-cms-erp/ci4msAffected
  • <0.31.2.0
Fixed in
  • 0.31.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in version 0.31.2.0 of ci4-cms-erp/ci4ms. Users and administrators should upgrade to this fixed version immediately to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A critical stored DOM-based blind cross-site scripting (XSS) vulnerability exists in the public-facing landing pages of the ci4-cms-erp/ci4ms platform. This flaw is located in the System Settings Company Information section and allows attackers to inject malicious scripts. Successful exploitation can lead to full account takeover and privilege escalation across all user roles, resulting in complete platform compromise. The vulnerability affects versions prior to 0.31.2.0 and has been assigned CVE-2026-35035 with a CVSS score of 9.1. A patch is available in version 0.31.2.0 to remediate this issue.

References

Community reviews

Loading reviews…