Skip to main content
Report · SecurityWeekAbout CVE-2026-48172Published

CISA Urges Immediate Patching of Exploited LiteSpeed cPanel Plugin Zero-Day

Source SecurityWeek

0
Compare
Authoritative record:CVE-2026-48172· Critical 10.0

Exploited in the wild · KEV due 29 May 2026 : upgrade to 2.4.7 now.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 2.4.7, 5.3.1.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 21 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: evidence found.

    Listed in CISA KEV 5 days after disclosure

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by MITRE Corporation

    , 1 minute before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 11 hours after disclosure

  4. , 5 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 8 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade cPanel Plugin to 2.4.7; WHM Plugin to 5.3.1.0.

Affected software

ProductAffectedFixed in
LiteSpeed TechnologiescPanel PluginAffected
  • >=2.3 <2.4.7
Fixed in
  • 2.4.7
LiteSpeed TechnologiesWHM PluginAffected
  • <5.3.1.0
Fixed in
  • 5.3.1.0

AI-suggested

A patch is available in LiteSpeed user-end plugin version 2.4.5 and WHM Plugin version 5.3.1.0 or higher (which bundles user-end plugin 2.4.7). Users should immediately upgrade to these versions to remediate the vulnerability. If patching is not possible, the vendor and cPanel recommend complete removal of the LiteSpeed user-end plugin. cPanel has also removed the vulnerable plugin from all cPanel versions via a nightly update. CISA mandates patching or removal by May 29, 2026, under BOD 22-01. Users should also review system logs and block any suspicious IPs identified during investigation as per vendor guidance.

Description

A critical zero-day vulnerability (CVE-2026-48172) in the LiteSpeed user-end plugin for cPanel was exploited in the wild to execute arbitrary scripts with root privileges. The vulnerability affects versions 2.3 through 2.4.4 of the plugin and was resolved in version 2.4.5. LiteSpeed’s WHM plugin is not affected. The vulnerability allows privilege escalation leading to unauthorized root access. CISA has added this vulnerability to its Known Exploited Vulnerabilities catalog and urges immediate patching or removal of the vulnerable plugin.

References

Community reviews

Loading reviews…