Skip to main content
VulnerabilityPublished Updated

CVE-2026-38992: cockpit-hq/cockpit · Cockpit is vulnerable to arbitrary code execution

Affects cockpit-hq/cockpitSource GCVE Database

0
Authoritative record:CVE-2026-38992· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 2.14.0 as a priority.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.14.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade cockpit-hq/cockpit to 2.14.0.

Affected software

ProductAffectedFixed in
Packagistcockpit-hq/cockpitAffected
  • <2.14.0
Fixed in
  • 2.14.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Cockpit versions 2.13.5 and earlier are vulnerable to arbitrary code execution via the filter parameter within multiple endpoints. This vulnerability allows an attacker to run system commands on the underlying infrastructure via the MongoLite $func operator.

References

Community reviews

Loading reviews…