Skip to main content
VulnerabilityPublished Updated

CVE-2026-93990: Coin3 · Expat through 2.8.4 fails to validate low surrogates following high surrogates in UTF-16

Affects coin3Source GCVE Database

0

Not known to be exploited · CVSS 7.5 High · fixed in 2.8.5 : patch coin3 soon.

Data as of 27 Oct 2026, 05:11 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.8.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10cadaverpkg:deb/ubuntu/cadaver?arch=source&distro=stonkingOther threatsAffected
  • =0.28+dfsg-2
Fixed in–
Ubuntu 26.10expatpkg:deb/ubuntu/expat?arch=source&distro=stonkingOther threatsAffected
  • 2.7.4-1 – 2.8.3-1ubuntu1
5 affected builds
Fixed in–
Ubuntu 26.10matanzapkg:deb/ubuntu/matanza?arch=source&distro=stonkingOther threatsAffected
  • =0.13+ds2-2build1
Fixed in–
Ubuntu 26.10swish-epkg:deb/ubuntu/swish-e?arch=source&distro=stonkingOther threatsAffected
  • =2.4.7-7.1
  • =2.4.7-7.2
  • =2.4.7-7.2build1
Fixed in–
Ubuntu 26.10tdompkg:deb/ubuntu/tdom?arch=source&distro=stonkingOther threatsAffected
  • =0.9.6-2
  • =0.9.6-3
Fixed in–
Ubuntu 26.10wbxml2pkg:deb/ubuntu/wbxml2?arch=source&distro=stonkingOther threatsAffected
  • =0.11.10+dfsg-3
  • =0.11.10+dfsg-4
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Expat through 2.8.4 fails to validate low surrogates following high surrogates in UTF-16 input, allowing malformed UTF-16 sequences to be accepted. Attackers can craft UTF-16 encoded XML with lone high surrogates that consume following code units, hiding markup characters from the parser and enabling XML injection attacks.

References

Community reviews

Loading reviews…