CVE-2026-0596: mlflow/mlflow · Command Injection
Affects mlflowSource GCVE Database
Not known to be exploited · CVSS 9.6 Critical : upgrade to 3.11.1 as a priority.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 70% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.11.1
CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade mlflow to 3.11.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimlflowpkg:bitnami/mlflowOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade mlflow to version 3.11.1 or later to remediate the issue. Until patched, avoid serving models with enable_mlserver=True from directories writable by untrusted or lower-privileged users to reduce risk.
Description
A command injection vulnerability exists in mlflow/mlflow when serving a model with the option enable_mlserver=True. The model_uri parameter is embedded directly into a shell command executed via bash without proper sanitization, allowing an attacker to execute arbitrary commands if shell metacharacters are included. This can lead to privilege escalation if the service runs with higher privileges and serves models from directories writable by lower-privileged users. The vulnerability affects versions prior to 3.11.1 and is classified as critical.