Skip to main content
VulnerabilityPublished

CVE-2026-118559: Commerce stripe · This module enables you to take payments via multiple Stripe APIs

Affects drupal/commerce_stripeSource GCVE Database

0

Not known to be exploited : upgrade to 2.2.3 or 1.4.0 when convenient.

Data as of 28 Oct 2026, 20:43 UTC

Severity
Medium

Rated Medium by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 2.2.3, 1.4.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade drupal/commerce_stripe to 2.2.3 or 1.4.0.

Affected software

ProductAffectedFixed in
Packagist https //packages.drupal.org/8drupal/commerce_stripeAffected
  • <1.4.0
  • >=2.0.0 <2.2.3
Fixed in
  • 1.4.0
  • 2.2.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to commerce_stripe versions 1.4.0 or 2.2.3 or later where this vulnerability is fixed. Ensure that the webhook signing secret is properly configured in the payment gateway settings to prevent improper processing of webhook events.

Description

The Drupal Commerce Stripe module allows payment processing via multiple Stripe APIs. A vulnerability exists where the module does not sufficiently verify the cryptographic signature of webhook events if the webhook signing secret is not properly configured. This issue is mitigated if a webhook signing secret is set or if the payment gateway plugin does not use webhooks. Fixed versions 1.4.0 and 2.2.3 address this vulnerability.

References

Community reviews

Loading reviews…