Com.thoughtworks.xstream:xstream: XStream is vulnerable to a Denial of Service attack due to stack overflow from a
Affects com.thoughtworks.xstream:xstreamSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.4.21 soon.
Data as of 31 Oct 2026, 01:26 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 1.4.21
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Nov 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade com.thoughtworks.xstream:xstream to 1.4.21.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavencom.thoughtworks.xstream:xstream | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to XStream version 1.4.21 or later, where the vulnerability is fixed by detecting input manipulation and preventing the stack overflow. If upgrading is not immediately possible, client code should catch StackOverflowError exceptions when using the BinaryStreamDriver to mitigate crashes.
Description
XStream versions prior to 1.4.21 are vulnerable to a denial of service (DoS) attack caused by a stack overflow when processing manipulated input streams using the BinaryStreamDriver. This vulnerability allows a remote attacker to crash the application by triggering a stack overflow error. The issue is fixed in version 1.4.21, which detects the manipulation and raises an InputManipulationException instead of crashing. Until patched, the only workaround is to catch the StackOverflowError in client code using the BinaryStreamDriver configuration.
References
- github.com/x-stream/xstream/security/advisories/GHSA-hfq9-hggm-c56q (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-47072 (opens in a new tab)
- github.com/x-stream/xstream/commit/bb838ce2269cac47433e31c77b2b236466e9f266 (opens in a new tab)
- github.com/x-stream/xstream/commit/fdd9f7d3de0d7ccf2f9979bcd09fbf3e6a0c881a (opens in a new tab)
- github.com/x-stream/xstream (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/12/msg00023.html (opens in a new tab)
- x-stream.github.io/CVE-2024-47072.html (opens in a new tab)