CVE-2026-42563: Conda lock · Dulwich Vulnerable to Command Injection via Merge Driver Path
Affects conda-lockSource GCVE Database
Not known to be exploited · CVSS 7.7 High : upgrade to 4.0.5 soon.
Data as of 4 Nov 2026, 20:35 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.0.5
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade conda-lock to 4.0.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewconda-lockpkg:brew/conda-lockOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in conda-lock version 4.0.5 that fixes this vulnerability. Users should upgrade to version 4.0.5 or later to remediate the issue. No additional mitigation is required if the patch is applied.
Description
Dulwich's merge driver functionality is vulnerable to command injection via the %P placeholder in merge driver commands. An attacker who can cause a victim to merge an untrusted branch with malicious file paths can execute arbitrary commands. This requires the victim to have a merge driver configured that uses the %P placeholder. The vulnerability affects conda-lock versions from 4.0.0 up to but not including 4.0.5 and is fixed in version 4.0.5.
References
- github.com/jelmer/dulwich/security/advisories/GHSA-9277-mp7x-85jf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-42563 (opens in a new tab)
- github.com/jelmer/dulwich/commit/e3331b3b3a122fc313460182f928f59723580b7b (opens in a new tab)
- github.com/jelmer/dulwich (opens in a new tab)
- github.com/jelmer/dulwich/releases/tag/dulwich-1.2.5 (opens in a new tab)