CVE-2024-5023: ConsoleMe has an Arbitrary File Read Vulnerability via Limited Git command
Affects consolemeSource GCVE Database
Not known to be exploited · CVSS 9.6 Critical : upgrade to 1.4.0 as a priority.
Data as of 27 Oct 2026, 17:41 UTC
- Patch
- Available – fixed in 1.4.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 16 May 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade consoleme to 1.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIconsoleme | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade ConsoleMe to version 1.4.0 or later, which contains the official fix. If upgrading is not possible, selectively apply the code changes from the referenced GitHub pull request. Alternatively, remove or set the 'cache_resource_templates.repositories' configuration to an empty array to disable templated resources, which mitigates the vulnerability but breaks templated resource functionality.
Description
ConsoleMe versions prior to 1.4.0 have an arbitrary file read vulnerability via a limited Git command flag injection. Authenticated users can read any files accessible by the ConsoleMe process, potentially exposing secrets used for AWS identity brokering. This vulnerability arises from improper sanitization of user-supplied filenames in templated resource requests, allowing flag injection in CLI commands. Deployments without templated resources configured are not affected. The issue is patched in ConsoleMe version 1.4.0.
References
- github.com/Netflix/consoleme/security/advisories/GHSA-3783-62vc-jr7x (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-5023 (opens in a new tab)
- github.com/Netflix/consoleme/pull/9380 (opens in a new tab)
- github.com/Netflix/consoleme/commit/2795a2bd553938a21c0643b37452971625ce67f5 (opens in a new tab)
- github.com/Netflix/consoleme (opens in a new tab)
- github.com/Netflix/security-bulletins/blob/master/advisories/nflx-2024-002.md (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/consoleme/PYSEC-2026-318.yaml (opens in a new tab)
- pypi.org/project/consoleme (opens in a new tab)