Consul-k8s versions 0.42.0 and later are vulnerable to a cross-namespace authorization bypass in component ACL binding
Source GCVE Database
Not known to be exploited · CVSS 9.9 Critical : upgrade to 2.0.4 as a priority.
Data as of 26 Oct 2026, 22:41 UTC
- Patch
- Available – fixed in 2.0.4, 1.8.18
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 26 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade Tooling to 2.0.4; Tooling to 1.8.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| HashiCorpTooling | Affected
| Fixed in
|
GitHubToolingpkg:github/ToolingOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Consul-k8s to version 2.1.0 or 1.8.18 where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the provided data.
Description
Consul-k8s versions 0.42.0 and later contain a critical vulnerability (CVE-2026-110720) involving a cross-namespace authorization bypass in component ACL binding rules. This flaw may allow attackers with limited privileges to escalate their Consul permissions. The issue is fixed in versions 2.1.0 and 1.8.18.