Skip to main content
VulnerabilityPublished Updated

CVE-2024-10086: Consul Vulnerable To Reflected XSS On Content-Type Error Manipulation

Affects consulSource GCVE Database

0

Not known to be exploited : upgrade to 1.20.0 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.20.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade consul to 1.20.0.

Affected software

ProductAffectedFixed in
Bitnamiconsulpkg:bitnami/consulOther threatsAffected
  • >=1.4.1 <1.20.0
Fixed in
  • 1.20.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade Consul and Consul Enterprise to versions 1.20.0 or later where this issue is fixed. Until patched, users should be aware of the risk of reflected XSS due to missing Content-Type headers in server responses.

Description

Consul and Consul Enterprise versions from 1.4.1 up to but not including 1.20.0 are affected by a reflected cross-site scripting (XSS) vulnerability. This occurs because the server response does not explicitly set a Content-Type HTTP header, allowing user input to be misinterpreted and reflected in the response. The vulnerability has a medium severity rating and a patch is available to address the issue.

References

Community reviews

Loading reviews…