Skip to main content
VulnerabilityPublished

CVE-2024-25621: github.com/containerd/containerd · containerd affected by a local privilege escalation via wide permissions on CRI directory

Affects github.com/containerd/containerdSource GCVE Database

0
Compare
Authoritative record:CVE-2024-25621· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 1.7.29 soon.

Data as of 4 Nov 2026, 18:37 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.3
Patch
Available – fixed in 1.7.29, 2.0.7, 2.1.5 +1
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Gogithub.com/containerd/containerdAffected
  • <1.7.29
Fixed in
  • 1.7.29
Gogithub.com/containerd/containerd/v2Affected
  • <2.0.7
Fixed in
  • 2.0.7
Gogithub.com/containerd/containerd/v2Affected
  • >=2.1.0-beta.0 <2.1.5
Fixed in
  • 2.1.5
Gogithub.com/containerd/containerd/v2Affected
  • >=2.2.0-beta.0 <2.2.0
Fixed in
  • 2.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in containerd versions 1.7.29, 2.0.7, 2.1.5, and 2.2.0, which automatically correct directory permissions. Users should update to these versions to resolve the issue. Alternatively, system administrators can manually restrict permissions on the affected directories by setting them to 700. Running containerd in rootless mode is another mitigation option. Note that some directories remain with 0o711 permissions intentionally to support user namespace remapping, which is expected behavior.

Description

CVE-2024-25621 is a local privilege escalation vulnerability in containerd caused by overly broad default permissions on certain directories. Specifically, /var/lib/containerd, /run/containerd/io.containerd.grpc.v1.cri, and /run/containerd/io.containerd.sandbox.controller.v1.shim were created with permissions that allowed local users to access sensitive metadata and volume contents, potentially leading to privilege escalation. The issue has been fixed in containerd versions 1.7.29, 2.0.7, 2.1.5, and 2.2.0. Users are advised to update to these versions or manually restrict directory permissions as a workaround. Running containerd in rootless mode is also a mitigation option.

References

Community reviews

Loading reviews…