Skip to main content
VulnerabilityPublished

CVE-2026-55824: contao/contao · Contao crawler leaks auth credentials to external hosts

Affects contao/contaoSource GCVE Database

0
Compare

Not known to be exploited · CVSS 2.6 Low : upgrade to 5.3.47 when convenient.

Data as of 7 Nov 2026, 23:24 UTC

CVSS 3.1 base score
2.6Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.3.47, 5.7.7
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade contao/contao and contao/core-bundle to 5.3.47; contao/contao and contao/core-bundle to 5.7.7.

Affected software

ProductAffectedFixed in
Packagistcontao/contaoAffected
  • >=4.13.0 <5.3.47
Fixed in
  • 5.3.47
Packagistcontao/contaoAffected
  • >=5.4.0 <5.7.7
Fixed in
  • 5.7.7
Packagistcontao/core-bundleAffected
  • >=4.13.0 <5.3.47
Fixed in
  • 5.3.47
Packagistcontao/core-bundleAffected
  • >=5.4.0 <5.7.7
Fixed in
  • 5.7.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available that correctly removes the Symfony HttpClient authentication options ('auth_basic', 'auth_bearer', 'auth_ntlm') from the cleaned client options used for external hosts. Users should update Contao to a fixed version at or beyond 5.3.47 or 5.7.7, depending on their version branch. Additionally, the factory test should be updated to properly verify that authentication options are not sent to external domains. Until patched, avoid enabling the broken-link checker with crawler authentication configured or restrict crawler access to trusted domains only.

Description

Contao's crawler has a vulnerability where authentication credentials configured for HTTP Basic or Bearer authentication can be leaked to external hosts during crawling. This occurs because the crawler's cleaning function removes incorrect option keys instead of the actual Symfony HttpClient authentication keys, causing credentials to be sent with requests to external URLs. An attacker can exploit this by causing the crawler to visit a malicious external URL, thereby receiving the crawler's credentials. The vulnerability affects Contao versions from 4.13.0 up to but not including 5.3.47, and from 5.4.0 up to but not including 5.7.7. A patch is available to fix the issue by properly stripping the correct authentication options.

References

Community reviews

Loading reviews…