Craft CMS from 5.7.0 before 5.11.2 contains an arbitrary file read vulnerability that allows authenticated control
Source GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 5.11.2 soon.
Data as of 8 Nov 2026, 18:17 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.5 |
- Patch
- Available – fixed in 5.11.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.
What to do
Upgrade cms to 5.11.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscms | Affected
| Fixed in
|
AI-suggested
A fixed version of Craft CMS is available starting from version 5.11.2. Users should upgrade to version 5.11.2 or later to remediate this vulnerability. No other mitigation or workaround is indicated in the provided data.
Description
Craft CMS versions from 5.7.0 up to but not including 5.11.2 contain an arbitrary file read vulnerability. Authenticated control panel users can exploit this flaw by sending crafted requests to the app/icon-svg endpoint to read SVG files via arbitrary paths. The vulnerability allows reading any SVG-content file accessible by the PHP process, including files outside the Craft installation directory.