CVE-2026-61846: Crass · Deeply nested CSS blocks and functions can trigger a SystemStackError or excessive memory usage
Affects crassSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 1.0.7 when convenient.
Data as of 29 Oct 2026, 17:11 UTC
- Patch
- Available – fixed in 1.0.7
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade crass to 1.0.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| RubyGemscrass | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to Crass version 1.0.7 or later, which includes a fix by adding a configurable recursion depth limit. As a temporary workaround, applications can catch and handle SystemStackError exceptions raised by Crass calls. Increasing available system memory may reduce impact but does not eliminate the vulnerability.
Description
Crass versions prior to 1.0.7 contain a vulnerability where deeply nested CSS blocks and functions can cause unbounded recursion, leading to a SystemStackError or excessive memory consumption. This issue arises because Crass lacks a depth guard when parsing CSS simple blocks and functions. The vulnerability is fixed in version 1.0.7 by introducing a configurable depth limit with a conservative default.