Skip to main content
Report · SecurityWeekAbout CVE-2026-41940Published

Critical cPanel & WHM Vulnerability Exploited as Zero-Day for Months

Source SecurityWeek

0
Compare
Authoritative record:CVE-2026-41940· Critical 9.3

Exploited in the wild · KEV due 3 May 2026 · public exploit available (Metasploit, Exploit-DB) : upgrade to 11.136.1.7 now.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 11.136.1.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 29 Apr 2026

  2. Exploited in the wild: evidence found.

    Listed in CISA KEV 1 day after disclosure

  3. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 7 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. In Threat Radar

    record ingested

    , 56 minutes after disclosure

  4. Added to CISA KEV (opens in a new tab)

    exploitation confirmed · ransomware use known

    , 1 day after disclosure

  5. KEV remediation due

    US federal deadline

    , 4 days after disclosure

  6. , 27 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade WP Squared to 11.136.1.7.

Affected software

ProductAffectedFixed in
WebProscPanelAffected
  • >=11.40.0.0 <11.86.0.41
  • >=11.88.0.0 <11.94.0.28
  • >=11.96.0.0 <11.102.0.39
  • >=11.104.0.0 <11.110.0.97
  • >=11.112.0.0 <11.118.0.63
  • >=11.120.0.0 <11.124.0.35
  • >=11.126.0.0 <11.126.0.54
  • >=11.128.0.0 <11.130.0.19
  • >=11.132.0.0 <11.132.0.29
  • >=11.134.0.0 <11.134.0.20
  • >=11.136.0.0 <11.136.0.5
Fixed in–
WebProsWP SquaredAffected
  • <11.136.1.7
Fixed in
  • 11.136.1.7
WebProsWHMAffected
  • >=11.40.0.0 <11.86.0.41
  • >=11.88.0.0 <11.94.0.28
  • >=11.96.0.0 <11.102.0.39
  • >=11.104.0.0 <11.110.0.97
  • >=11.112.0.0 <11.118.0.63
  • >=11.120.0.0 <11.124.0.35
  • >=11.126.0.0 <11.126.0.54
  • >=11.128.0.0 <11.130.0.19
  • >=11.132.0.0 <11.132.0.29
  • >=11.134.0.0 <11.134.0.20
  • >=11.136.0.0 <11.136.0.5
Fixed in–
GitHubwebpros/cpanelpkg:github/webpros/cpanelOther threatsAffected
  • 11.40.0.0 – 11.136.0.0
11 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Official patches addressing this vulnerability have been released in cPanel & WHM versions 11.86.0.41, 11.110.0.97, 11.118.0.63, 11.126.0.54, 11.130.0.19, 11.132.0.29, 11.136.0.5, and 11.134.0.20, as well as WP Squared version 136.1.7. It is strongly recommended to immediately update to one of these patched versions. If running unsupported versions, upgrading to a supported version eligible for the update is highly advised. Hosting providers have also mitigated risk by blocking access to cPanel & WHM ports during patch deployment. Detection scripts published by cPanel and WatchTowr should be used to identify signs of compromise. Patch status is confirmed as official fix available.

Description

A critical authentication bypass vulnerability (CVE-2026-41940) in cPanel & WHM has been exploited as a zero-day for months, allowing remote unauthenticated attackers to gain administrative access to affected servers. This flaw affects all versions after 11.40 and enables attackers to take control of the cPanel host system, modify server configurations, and potentially compromise all websites on shared hosting servers. The vulnerability involves manipulation of session files and cookies during the login flow. Multiple hosting providers have blocked access and deployed patches included in various cPanel versions starting from 11.86.0.41 onward. Detection tools have been released to identify signs of compromise. Immediate patching is strongly recommended to mitigate the risk.

References

Community reviews

Loading reviews…