Skip to main content
VulnerabilityPublished Updated

CVE-2026-98432: Critical · kernel security update

Affects bpftoolSource GCVE Database

0
Compare
Authoritative record:CVE-2026-98432· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 4.18.0-553.182.1.el8_10 as a priority.

Data as of 2 Nov 2026, 13:29 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Linux)CVSS 3.19.8
Patch
Available – fixed in 4.18.0-553.182.1.el8_10
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade the AlmaLinux to 4.18.0-553.182.1.el8_10.

Affected software

ProductAffectedFixed in
AlmaLinux 8bpftoolAffected
  • <4.18.0-553.182.1.el8_10
Fixed in
  • 4.18.0-553.182.1.el8_10
AlmaLinux 8kernelAffected
  • <4.18.0-553.182.1.el8_10
Fixed in
  • 4.18.0-553.182.1.el8_10
AlmaLinux 8kernel-abi-stablelistsAffected
  • <4.18.0-553.182.1.el8_10
Fixed in
  • 4.18.0-553.182.1.el8_10
AlmaLinux 8kernel-coreAffected
  • <4.18.0-553.182.1.el8_10
Fixed in
  • 4.18.0-553.182.1.el8_10
AlmaLinux 8kernel-cross-headersAffected
  • <4.18.0-553.182.1.el8_10
Fixed in
  • 4.18.0-553.182.1.el8_10
AlmaLinux 8kernel-debugAffected
  • <4.18.0-553.182.1.el8_10
Fixed in
  • 4.18.0-553.182.1.el8_10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing this vulnerability is available in kernel version 4.18.0-553.182.1.el8_10 and later. Red Hat advises applying this update promptly and rebooting the system for the fix to take effect. Delaying the update may leave systems exposed. No additional mitigation steps are indicated beyond applying the official patch and rebooting.

Description

A critical security vulnerability (CVE-2026-98432) exists in the Linux kernel's IPv4 implementation related to freeing inet_opt and ireq_opt after an RCU grace period. This flaw affects Red Hat Enterprise Linux 8 kernel packages prior to version 4.18.0-553.182.1.el8_10. A security update has been released by Red Hat to address this issue, and a system reboot is required to apply the fix.

References

Community reviews

Loading reviews…