Skip to main content
VulnerabilityPublished Updated

CVE-2026-3857: GitLab · Cross-Site Request Forgery (CSRF)

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 18.10.1 : patch gitlab soon.

Data as of 26 Oct 2026, 09:16 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.10.1, 18.9.3, 18.8.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade gitlab to 18.10.1, 18.9.3 or 18.8.7.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=17.10.0 <18.8.7
  • >=18.9.0 <18.9.3
  • >=18.10.0 <18.10.1
Fixed in
  • 18.8.7
  • 18.9.3
  • 18.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitLab CE/EE to versions 18.8.7, 18.9.3, or 18.10.1 or later to apply the official fix. Since a patch is available, applying the update is the recommended remediation.

Description

A Cross-Site Request Forgery (CSRF) vulnerability in GitLab CE/EE allows unauthenticated users to execute arbitrary GraphQL mutations on behalf of authenticated users. This issue affects GitLab versions from 17.10 up to but not including 18.8.7, 18.9 up to but not including 18.9.3, and 18.10 up to but not including 18.10.1. The vulnerability is due to insufficient CSRF protection. A patch is available that addresses this issue.

References

Community reviews

Loading reviews…