CVE-2024-37674: Moodle CMS · Cross Site Scripting Vulnerability
Affects moodleSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium : upgrade to 4.1.10 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.10
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 20 Jun 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade moodle to 4.1.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Bitnamimoodlepkg:bitnami/moodleOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users should upgrade Moodle to version 4.1.10 or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.
Description
A Cross Site Scripting (XSS) vulnerability exists in Moodle CMS version 3.10, allowing a remote attacker to execute arbitrary code via the Field Name (name parameter) of a new activity. This vulnerability affects Moodle versions from 3.10.0 up to but not including 4.1.10. A patch is available to address this issue. The severity is assessed as medium based on the available information.