Skip to main content
CVE-2026-106143VulnerabilityPublished

Progress Software Kendo UI · Cross-Site Scripting (XSS)

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-106143· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium : upgrade to 10.1.0 when convenient.

Data as of 6 Nov 2026, 19:20 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (ProgressSoftware)CVSS 3.15.4
Patch
Available – fixed in 10.1.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade Kendo UI for Vue and @progress/kendo-vue-editor to 10.1.0.

Affected software

ProductAffectedFixed in
Kendo UI for Vue@progress/kendo-vue-editorAffected
  • >=2.7.1 <10.1.0
Fixed in
  • 10.1.0
npm@progress/kendo-vue-editorpkg:npm/@progress/kendo-vue-editorOther threatsAffected
  • >=2.7.1 <10.1.0
Fixed in
  • 10.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should exercise caution when accepting content from untrusted sources in the Editor component, especially links or images. Avoid clicking suspicious links generated via the Insert Link or Insert Image dialogs.

Description

A Cross-Site Scripting (XSS) vulnerability exists in the Editor component (@progress/kendo-vue-editor) of Progress Software Kendo UI for Vue versions 2.7.1 through 10.0.0. This flaw allows a low-privileged attacker who can supply content to the Editor to execute arbitrary JavaScript in another user's browser by entering an unsafe URL in the Insert Link or Insert Image dialog. The malicious script executes when the user clicks the resulting link.

References

Community reviews

Loading reviews…