Skip to main content
CVE-2026-44243VulnerabilityPublished Updated

Cruft: GitPython reference APIs has a path traversal vulnerability that allows arbitrary file write and delete outside

Affects cruftSource GCVE Database

0
Authoritative record:CVE-2026-44243· High 7.8

Public exploit available · CVSS 7.8 High : upgrade to 2.16.0_8 as a priority.

Data as of 26 Oct 2026, 17:44 UTC

CVSS 4.0 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.16.0_8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade cruft to 2.16.0_8.

Affected software

ProductAffectedFixed in
Homebrewcruftpkg:brew/cruftOther threatsAffected
  • >=2.9.0 <2.16.0_8
Fixed in
  • 2.16.0_8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 2.16.0_8 that enforces strict validation of reference paths before write, rename, and delete operations to ensure they do not escape the repository boundaries. Users should upgrade to this fixed version or later. The vulnerability requires local attacker control over reference names passed to GitPython APIs, so restricting untrusted input to these APIs is also recommended.

Description

GitPython versions up to 3.1.46 and the current main branch (3.1.47 locally) contain a path traversal vulnerability in their reference APIs. This flaw allows attackers who can supply crafted reference paths to write, overwrite, move, or delete files outside the repository's .git directory due to insufficient validation of reference paths during write, rename, and delete operations. The vulnerability requires local access to influence reference names passed to GitPython. It can lead to high integrity and availability impacts by corrupting or deleting files outside the repository metadata.

References

Community reviews

Loading reviews…