CVE-2026-86409: curl vulnerabilities
Affects curlSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.1 High · fixed in 7.35.0-1ubuntu2.20+esm24 : patch curl soon.
Data as of 31 Oct 2026, 04:23 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 8.1 |
|---|
- Patch
- Available – fixed in 7.35.0-1ubuntu2.20+esm24, 7.47.0-1ubuntu2.19+esm21, 7.58.0-2ubuntu3.24+esm15 +3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 24.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Ubuntu Pro 16.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in
|
Ubuntu Pro 14.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and users should update curl packages to the versions listed in the Ubuntu security advisory USN-8932-1. For Ubuntu 24.04 LTS, update to curl 8.5.0-2ubuntu10.16 or later; for 22.04 LTS, update to 7.81.0-1ubuntu1.30 or later; for 20.04 LTS, 7.68.0-1ubuntu2.25+esm10 or later; for 18.04 LTS, 7.58.0-2ubuntu3.24+esm15 or later; for 16.04 LTS, 7.47.0-1ubuntu2.19+esm21 or later; and for 14.04 LTS, 7.35.0-1ubuntu2.20+esm24 or later. Standard system updates will apply these fixes. No additional mitigation steps are indicated by the vendor advisory.
Description
Multiple security vulnerabilities were discovered in curl affecting various Ubuntu LTS releases. These include improper clearing of AWS SigV4 authentication state, HTTP proxy authentication challenges leading to credential exposure, incorrect handling of HSTS entries causing potential downgrade to unencrypted connections, denial of service via malformed HSTS max-age values, IMAP command injection, use-after-free in FTP wildcard matching, TFTP transfer direction validation flaws, stack overflow in MIME processing, and exposure of credentials via CURLINFO_EFFECTIVE_URL. These issues could lead to information disclosure, denial of service, or arbitrary code execution. Fixes have been released for affected Ubuntu versions.
References
- ubuntu.com/security/notices/USN-8932-1 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86409 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86414 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87862 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87863 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87864 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92388 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92389 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92391 (opens in a new tab)
- ubuntu.com/security/CVE-2026-94266 (opens in a new tab)