CVE-2026-86409: curl vulnerabilities
Affects curlSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.1 High : upgrade to 8.18.0-1ubuntu2.8 soon.
Data as of 31 Oct 2026, 04:23 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 8.1 |
|---|
- Patch
- Available – fixed in 8.18.0-1ubuntu2.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu curl package to 8.18.0-1ubuntu2.8.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTScurlpkg:deb/ubuntu/curl?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and users should update curl to version 8.18.0-1ubuntu2.8 or later as provided by the Ubuntu security notice USN-8927-1. Applying this update will address all listed vulnerabilities. No additional mitigation actions are required beyond applying the official fix.
Description
Multiple security vulnerabilities were discovered in curl affecting various features including GnuTLS WebSocket handling, AWS SigV4 authentication state, SSH host verification, cookie handling, HTTP proxy authentication, HSTS processing, IMAP command injection, FTP wildcard matching, TFTP transfer validation, file overwrite protection, MIME processing, and HTTP/2 upload handling. These issues could allow attackers to obtain sensitive information, cause denial of service, perform machine-in-the-middle attacks, overwrite local files, or execute arbitrary code. The vulnerabilities are addressed in updated curl packages.
References
- ubuntu.com/security/notices/USN-8927-1 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86409 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86410 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86412 (opens in a new tab)
- ubuntu.com/security/CVE-2026-86414 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87862 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87863 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87864 (opens in a new tab)
- ubuntu.com/security/CVE-2026-87865 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92386 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92387 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92388 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92389 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92390 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92391 (opens in a new tab)
- ubuntu.com/security/CVE-2026-92392 (opens in a new tab)
- ubuntu.com/security/CVE-2026-94266 (opens in a new tab)
- ubuntu.com/security/CVE-2026-107928 (opens in a new tab)
- ubuntu.com/security/CVE-2026-107929 (opens in a new tab)