Skip to main content
VulnerabilityPublished Updated

CVE-2018-1000168: nghttp2 · NULL Pointer Dereference

Source CVE Database V5

0

Not known to be exploited · 10% EPSS · CVSS 7.5 High · fixed in 1.10.0 : patch affected systems soon.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
10.5% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.10.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 May 2018

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
n/a n/aAffected
  • >=1.10.0
  • <=1.31.0
  • <1.10.0
Fixed in
  • 1.10.0

AI-suggested

European organizations should immediately verify whether their infrastructure uses nghttp2 versions between 1.10.0 and 1.31.0. If so, upgrading to version 1.31.1 or later is essential to remediate the vulnerability. Organizations should audit all software components and dependencies that incorporate nghttp2, including web servers, reverse proxies, HTTP/2 clients, and embedded systems. Where immediate patching is not feasible, implementing network-level mitigations such as rate limiting, deep packet inspection, or firewall rules to detect and block malformed ALTSVC frames can reduce exposure. Monitoring application logs for crashes or segmentation faults related to HTTP/2 traffic can help detect exploitation attempts. Additionally, organizations should ensure robust incident response plans are in place to quickly address potential denial of service events. Regular vulnerability scanning and dependency management practices should be enforced to prevent similar issues.

Description

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

References

Community reviews

Loading reviews…