CVE-2021-3187: BeyondTrust Privilege Management · Incorrect Default Permissions
Source CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 5.7 : patch affected systems soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 11 Dec 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n/a n/a | Affected
| Fixed in
|
AI-suggested
To mitigate this vulnerability, European organizations should: 1) Immediately upgrade BeyondTrust Privilege Management for Mac to version 5.7 or later, which addresses this issue. 2) Ensure all macOS systems are updated to at least version 10.15.5 or later, or have applied Security Update 2020-003 on Mojave and High Sierra. 3) Restrict installation privileges and monitor installation processes to detect unauthorized script execution. 4) Implement strict access controls to limit unprivileged user capabilities and monitor for unusual activity in temporary directories. 5) Employ endpoint detection and response (EDR) solutions capable of detecting privilege escalation attempts. 6) Conduct regular audits of installed software and system configurations to identify vulnerable versions. 7) Educate users and administrators about the risks of running untrusted scripts and the importance of applying security updates promptly.
Description
An issue was discovered in BeyondTrust Privilege Management for Mac before 5.7. An authenticated, unprivileged user can elevate privileges by running a malicious script (that executes as root from a temporary directory) during install time. (This applies to macOS before 10.15.5, or Security Update 2020-003 on Mojave and High Sierra, Later versions of macOS are not vulnerable.)