Skip to main content
VulnerabilityPublished Updated

CVE-2021-40528: Libgcrypt · Weak Cryptography

Source CVE Database V5

0

Not known to be exploited · CVSS 5.9 Medium : upgrade to 1.9.4 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.4% chance of exploitation in 30 days – higher than 72% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.9.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Sep 2021

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/libgcrypt package to 1.9.4.

Affected software

ProductAffectedFixed in
Debiandebian/libgcryptpkg:deb/debian/libgcryptOther threatsAffected
  • <1.9.4
Fixed in
  • 1.9.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should first identify whether their systems use Libgcrypt versions prior to 1.9.4, especially in applications handling OpenPGP encryption. Immediate mitigation steps include upgrading Libgcrypt to version 1.9.4 or later, where the vulnerability is addressed. If upgrading is not immediately feasible, organizations should consider disabling or avoiding the use of ElGamal encryption within OpenPGP configurations or switching to alternative cryptographic algorithms not affected by this vulnerability. Additionally, organizations should audit cryptographic parameter configurations to avoid the dangerous combinations of primes, generators, and ephemeral exponents that enable the attack. Monitoring cryptographic libraries and applications for updates and applying patches promptly is critical. Finally, organizations should review encrypted communications for potential exposure and consider re-encrypting sensitive data with secure configurations post-patch.

Description

The ElGamal implementation in Libgcrypt before 1.9.4 allows plaintext recovery because, during interaction between two cryptographic libraries, a certain dangerous combination of the prime defined by the receiver's public key, the generator defined by the receiver's public key, and the sender's ephemeral exponents can lead to a cross-configuration attack against OpenPGP.

References

Community reviews

Loading reviews…