Skip to main content
VulnerabilityPublished Updated

CVE-2023-45362: mediawiki · CVE-2023-45362 is an information leak

Affects mediawikiSource CVE Database V5

0

Not known to be exploited · fixed in 1.40.1 : update mediawiki when convenient.

Data as of 26 Oct 2026, 17:16 UTC

Severity
Medium

Rated Medium by the CNA (mitre) · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.40.1, 1.39.5, 1.35.12

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mediawiki/mediawiki to 1.40.1, 1.39.5 or 1.35.12.

Affected software

ProductAffectedFixed in
Packagistmediawiki/mediawikipkg:composer/mediawiki/mediawikiOther threatsAffected
  • <1.35.12
  • >=1.36.0 <1.39.5
  • >=1.40.0 <1.40.1
Fixed in
  • 1.35.12
  • 1.39.5
  • 1.40.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions are available: 1.35.12, 1.39.5, and 1.40.1. Users should upgrade to these versions or later to remediate the vulnerability. No additional mitigation steps are indicated.

Description

CVE-2023-45362 is an information leak vulnerability in MediaWiki's DifferenceEngine.php component. It affects versions prior to 1.35.12, versions from 1.36.0 up to but excluding 1.39.5, and versions from 1.40.0 up to but excluding 1.40.1. The flaw causes intermediate revisions by the same user to ignore username suppression, potentially exposing user information that should be hidden.

References

Community reviews

Loading reviews…