Skip to main content
VulnerabilityPublished Updated

CVE-2023-51704: mediawiki · CVE-2023-51704 is a cross-site scripting (XSS)

Affects mediawikiSource CVE Database V5

0

Not known to be exploited · fixed in 1.40.2 : update mediawiki when convenient.

Data as of 26 Oct 2026, 17:16 UTC

Severity
Medium

Rated Medium by the CNA (mitre) · No CVSS score from NVD or the CNA

EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.40.2, 1.39.6, 1.35.14

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Dec 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade mediawiki/mediawiki to 1.40.2, 1.39.6 or 1.35.14.

Affected software

ProductAffectedFixed in
Packagistmediawiki/mediawikipkg:composer/mediawiki/mediawikiOther threatsAffected
  • <1.35.14
  • >=1.36.0 <1.39.6
  • >=1.40.0 <1.40.2
Fixed in
  • 1.35.14
  • 1.39.6
  • 1.40.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrading MediaWiki to version 1.35.14, 1.39.6, or 1.40.2 or later fully mitigates this vulnerability. Users should apply these official fixes to prevent exploitation.

Description

CVE-2023-51704 is a cross-site scripting (XSS) vulnerability in MediaWiki affecting certain versions prior to 1.35.14, between 1.36.0 and before 1.39.6, and between 1.40.0 and before 1.40.2. The issue arises in the RightsLogFormatter.php component, where group-*-member messages can lead to XSS on the Special:log/rights page. Fixed versions are 1.35.14, 1.39.6, and 1.40.2.

References

Community reviews

Loading reviews…