Skip to main content
VulnerabilityPublished Updated

CVE-2023-51764: postfix · CVE-2023-51764 is a

Affects postfixSource CVE Database V5

0

Not known to be exploited.

Data as of 26 Oct 2026, 13:47 UTC

Severity
Medium

Rated Medium by the CNA (mitre) · No CVSS score from NVD or the CNA

EPSS
2.6% chance of exploitation in 30 days – higher than 85% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Dec 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Debianpostfixpkg:deb/postfixOther threatsAffected
  • <=3.8.5
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Partial mitigation is possible by configuring Postfix with smtpd_data_restrictions=reject_unauth_pipelining and smtpd_discard_ehlo_keywords=chunking, which blocks misuse of SMTP command pipelining but does not fully address message pipelining or malformed line endings. The only complete remediation is to upgrade Postfix to versions 3.5.23, 3.6.13, 3.7.9, 3.8.4, 3.9 or later and enable smtpd_forbid_bare_newline=yes. Users should follow vendor advisories and apply package updates when available.

Description

CVE-2023-51764 is a vulnerability in Postfix versions up to 3.8.5 that allows SMTP smuggling due to default configurations accommodating older SMTP clients. This flaw enables remote attackers to inject email messages with spoofed MAIL FROM addresses, potentially bypassing SPF protections. The issue arises because Postfix supports a non-standard line ending sequence (<LF>.<CR><LF>) that some other mail servers do not. Partial mitigations exist via configuration options, but a complete fix requires package updates to versions including the smtpd_forbid_bare_newline option.

References

Community reviews

Loading reviews…