Skip to main content
CVE-2024-10124VulnerabilityPublished Updated

CVE-2024-10124: Vayu Blocks (WordPress plugin) · Improper Access Control

Affects Vayu Blocks (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · 32% EPSS · CVSS 9.8 Critical · fixed in 1.1.1 : patch Vayu Blocks (WordPress plugin) as a priority.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
32.7% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.1.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
themehunk Vayu Blocks – Website Builder for the Block EditorAffected
  • =0
Fixed in–

AI-suggested

Version 1.1.1 includes only a partial patch, so upgrading to this version may reduce risk but does not fully mitigate the vulnerability. Until a full fix is released, restrict access to plugin installation functions and monitor for suspicious activity. Avoid installing untrusted plugins that could be leveraged in combination with this vulnerability.

Description

The Vayu Blocks – Gutenberg Blocks for WordPress & WooCommerce plugin for WordPress is vulnerable to unauthorized arbitrary plugin installation and activation due to a missing capability check on the tp_install() function in all versions up to, and including, 1.1.1. This makes it possible for unauthenticated attackers to install and activate arbitrary plugins which can be leveraged to achieve remote code execution if another vulnerable plugin is installed and activated. This vulnerability was partially patched in version 1.1.1.

References

Community reviews

Loading reviews…