Skip to main content
VulnerabilityPublished

CVE-2024-10242: WSO2 API Manager · Cross-site Scripting

Affects WSO2 API ManagerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.0.0.318 or 3.2.0.401 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.0.318, 3.2.0.401
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade WSO2 API Manager to 4.0.0.318 or 3.2.0.401.

Affected software

ProductAffectedFixed in
WSO2WSO2 API ManagerAffected
  • >=4.0.0 <4.0.0.318
Fixed in
  • 4.0.0.318
WSO2WSO2 API ManagerAffected
  • >=3.2.0 <3.2.0.401
Fixed in
  • 3.2.0.401
Mavenorg.wso2/carbon-apimgtpkg:maven/org.wso2/carbon-apimgtOther threatsAffected
  • =3.2.0
  • =4.0.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should exercise caution when interacting with the authentication endpoint and consider implementing additional input validation or web application firewall rules to detect and block malicious payloads targeting this vulnerability.

Description

The authentication endpoint fails to adequately validate user-supplied input before reflecting it back in the response. This allows an attacker to inject malicious script payloads into the input parameters, which are then executed by the victim's browser. Successful exploitation can enable an attacker to redirect the user's browser to a malicious website, modify the UI of the web page, or retrieve information from the browser. However, the impact is limited as session-related sensitive cookies are protected by the httpOnly flag, preventing session hijacking.

References

Community reviews

Loading reviews…