Skip to main content
VulnerabilityPublished Updated

CVE-2024-10552: Flexmls® IDX Plugin · Cross-site Scripting

Affects Flexmls® IDX PluginSource CVE Database V5

0

Not known to be exploited · CVSS 6.4 Medium · fixed in 3.14.25 : update Flexmls® IDX Plugin when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.14.25
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
flexmls Flexmls® IDX PluginAffected
  • =0
Fixed in–

AI-suggested

A partial fix was introduced in version 3.14.25, but the vulnerability remains in 3.14.26. Users should verify with the vendor for updated patches or advisories. Until a full fix is available, restrict Contributor-level access to trusted users only and monitor for suspicious activity related to the plugin.

Description

The Flexmls® IDX Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘api_key’ and 'api_secret' parameters in all versions up to, and including, 3.14.26 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 3.14.25.

References

Community reviews

Loading reviews…