Skip to main content
VulnerabilityPublished Updated

CVE-2024-10976: PostgreSQL · Improper Preservation of Consistency Between Independent Representations of Shared State

Affects PostgreSQLSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 4.2 Medium · fixed in 17.1 : update PostgreSQL when convenient.

Data as of 30 Oct 2026, 02:09 UTC

CVSS 3.1 base score
4.2Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (PostgreSQL)CVSS 3.14.2
Patch
Available – fixed in 17.1, 16.5, 15.9 +3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PostgreSQLAffected
  • <17.1
  • <16.5
  • <15.9
  • <14.14
  • <13.17
  • <12.21
Fixed in
  • 17.1
  • 16.5
  • 15.9
  • 14.14
  • 13.17
  • 12.21

AI-suggested

Fixed versions are PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21. Users should upgrade to these or later versions to remediate the vulnerability. No vendor advisory content was provided to indicate otherwise. Until patched, users should carefully review the use of row-level security policies in conjunction with query plan reuse and role changes. Patch status is confirmed by the presence of fixed versions.

Description

CVE-2024-10976 is a vulnerability in PostgreSQL affecting versions prior to 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21. It involves improper preservation of consistency between independent representations of shared state related to row-level security policies. Specifically, reused queries may apply incorrect row security policies when executed under different roles than those used during query planning, potentially allowing unauthorized reads or modifications. This issue affects databases using CREATE POLICY to define row security and requires an attacker to tailor the attack to specific application query patterns and role changes.

References

Community reviews

Loading reviews…